Scion XD Forum

Scion XD Forum (http://www.scionxdforum.com/forum/index.php)
-   General Discussion (http://www.scionxdforum.com/forum/forumdisplay.php?f=23)
-   -   Common XD issues/glitches/recalls (http://www.scionxdforum.com/forum/showthread.php?t=1214)

Vengeful Squid 04-03-2011 02:56 PM

Common XD issues/glitches/recalls
 
New XD owner here. I know our cars fall under toyota's 'excellent reliability'/low maintenance cost umbrella, but are there common issues with the XD, and if so are they specific to particular model years? Trying to get educated. Didn't see any related sticky to this.

Whack-A-Mole 04-03-2011 05:52 PM

08-09 had a recall for replacing some vacuum hoses because at -20 below freezing after a week or so ice could accumulate ( I think it was on the Pcv valve) and reduce vacumm pressure. Which would mess up the brake assist, which can increase braking distance.

Across all models though some complain in extreme cold the 5 speed gearbox can be slushy. I don't have that problem. There's a TSB for oil consumption issue where they reflash your ECU to retard the timing. Last is just odd vibrations through the dash or door panels because our cars just snap together or pull apart. Really it makes it easy to work on, and my vibrations are minimal. That's all I can think of off the top of my head. Aftermarket support could be better.

JDMJim 04-03-2011 08:06 PM

I was having cruise control issues yesterday. it wouldn't lock onto a speed. worked fine later in the day, so idk. But I have been having this intermittent problem

simmons0613 04-03-2011 08:56 PM

I havent had any problems so far... I have a '08 model and so far no problems. The previous owner didn't take it in for the recall but still no problem. I bought it only a year old.

mcbrew 04-03-2011 10:52 PM

Just to clarify terminology: the recall issue didn't affect "brake assist," it could reduce vacuum assist. Brake assist is a system that our xDs have which applies full braking if it detects an emergency braking situation.

Back on topic: I have not needed anything other than the recall. Everything else has been oil changes, tires, or my own mods (mainly switching to higher quality fluids).

Vengeful Squid 04-04-2011 09:24 AM

Quote:

Originally Posted by Whack-A-Mole (Post 10146)
08-09 had a recall for replacing some vacuum hoses because at -20 below freezing after a week or so ice could accumulate ( I think it was on the Pcv valve) and reduce vacumm pressure. Which would mess up the brake assist, which can increase braking distance.

Across all models though some complain in extreme cold the 5 speed gearbox can be slushy. I don't have that problem. There's a TSB for oil consumption issue where they reflash your ECU to retard the timing. so is this oil consumption issue just for manual transmissions? this sounds SERIOUS! is this for all year XD's? did you have to go through the TSB?Last is just odd vibrations through the dash or door panels because our cars just snap together or pull apart. Really it makes it easy to work on, and my vibrations are minimal. That's all I can think of off the top of my head. Aftermarket support could be better.hmm. i just assumed that aftermarket support would be good because scions are known for being customized. guess only love for the xb's. thanks for the post.

my answers above in red

mcbrew 04-04-2011 03:17 PM

Oil consumption was for '08 models. My '09 does not burn oil during a 10,000 mile OCI.

TexXBox 04-07-2011 10:47 PM

Quote:

Originally Posted by JDMJim (Post 10149)
I was having cruise control issues yesterday. it wouldn't lock onto a speed. worked fine later in the day, so idk. But I have been having this intermittent problem

Sounds silly, but you might try double checking your brake lights. The way most vehicles detect when to shut off the cruise during braking is via the brake light circuit. If the cruise detects any anomaly during its self test during initialization it won't activate for fear it won't de-activate when neccessary. A bad or loose bulb or contact will shut down the cruise before it even starts. And can drive you nuts trying to sort out if it is intermittent.

beckiraye 06-12-2011 11:08 AM

Yes I see many people complaining about water leaking under the dashboard into the car. This is happening to me for the second summer. Last summer I took my car to Montrose Scion in Akron and the mechanic told me I must have mice under my hood. Well now I see many other people complaining about this. It is humid here in Ohio in the summer .I need my air conditioning. I about ready to trade in this car.

---------- Post added at 11:08 AM ---------- Previous post was at 11:06 AM ----------

Quote:

Originally Posted by Vengeful Squid (Post 10143)
New XD owner here. I know our cars fall under toyota's 'excellent reliability'/low maintenance cost umbrella, but are there common issues with the XD, and if so are they specific to particular model years? Trying to get educated. Didn't see any related sticky to this.

water under dashboard leaking into my car both summers I have owned my car.

XDevolution 06-12-2011 11:15 PM

i have vibrations comin from driver side door as well as from windshield area by the defogger. its annoying but managable.whatever the dash is made out of scratches and damages real easily. idk if maybe there is water leakage but it def smells alittle damp sumtimes in my car (i vacuum and scrub all fabric atleast once a week) and after about 3 days it starts to smell again. make friends with air fresheners or car sprays IMO. hmmm other than that i really have no complaints. i love my car, i just wish there was more aftermarket support.

CXTKRS1 06-13-2011 01:52 AM

Seems quite a few members on other boards are having alt issues too.

simmons0613 06-13-2011 07:20 AM

*knocking on wood* So far so good for mine. I only have a few cosmetic issues (scratches/dents)

Resolve 06-13-2011 10:45 AM

Quote:

Originally Posted by beckiraye (Post 11098)
Yes I see many people complaining about water leaking under the dashboard into the car. This is happening to me for the second summer. Last summer I took my car to Montrose Scion in Akron and the mechanic told me I must have mice under my hood. Well now I see many other people complaining about this. It is humid here in Ohio in the summer .I need my air conditioning. I about ready to trade in this car.

Mechanic is an idiot.. So he didn't even check the issue. The fix is easy for Toyota mechanics. What happens is dirt and debris clogs the drain tube for the a/c and it backs up into the car. just needs to be cleared. Then heard some people are using in cabin filter and it has solved the clogging issue. I have done this yet.

XDevolution 06-13-2011 09:47 PM

my alternator actually blew about 2 weeks ago. i got a rebuilt one with a lighter overdrive pulley, good investment. all my electronics run way better, the car seems alittle more responsive off the line.

simmons0613 06-13-2011 10:53 PM

Quote:

Originally Posted by Resolve (Post 11109)
Mechanic is an idiot.. So he didn't even check the issue. The fix is easy for Toyota mechanics. What happens is dirt and debris clogs the drain tube for the a/c and it backs up into the car. just needs to be cleared. Then heard some people are using in cabin filter and it has solved the clogging issue. I have done this yet.

Just to add on about the cabin filter that most of us know about... The filter is located behind the lower glove compartment. As far as I know, walmart doesn't carry this filter but Auto-Zone does.

---------- Post added at 11:53 PM ---------- Previous post was at 11:52 PM ----------

Quote:

Originally Posted by XDevolution (Post 11116)
my alternator actually blew about 2 weeks ago. i got a rebuilt one with a lighter overdrive pulley, good investment. all my electronics run way better, the car seems alittle more responsive off the line.

XDevolution, just a quick question. Are you running a manual or auto tranny?

braden181818 01-26-2013 06:12 PM

Need Help with Electric Issue
 
I have a 2008 Scion XD. Was driving the car down the highway on a slightly rainy day. Out of nowhere the Powersteering went out, the wipers stopped working, the Heater/AC stopped, the blinkers stoped working, the radio went out, the windows stopped working and there were random lights on the dash like the Brake light, and some other random ones, but not the battery light. The car still kept running fine other wise. The alternator is fine, the battery is good, there were no blown fuses. Could this all be caused by the power steering ECU, or maybe the Engine ECU?

JDMJim 02-19-2013 04:40 PM

Quote:

Originally Posted by simmons0613 (Post 11124)
Just to add on about the cabin filter that most of us know about... The filter is located behind the lower glove compartment. As far as I know, walmart doesn't carry this filter but Auto-Zone does.

---------- Post added at 11:53 PM ---------- Previous post was at 11:52 PM ----------



XDevolution, just a quick question. Are you running a manual or auto tranny?

if Toyota would stop being extra cheap and just put a filter in there....smdh

---------- Post added at 04:40 PM ---------- Previous post was at 04:38 PM ----------

I figured out the cruise control setting problem I have....Can't rest my foot on the clutch when trying to set the speed...

I still have eggs in my vvti....if I even come close to tapping the bg lobes, the eggs are cookin in my tail pipe....it's nasty and embarrassing

trashcanman 06-02-2014 07:04 PM

Hello there I have a 2010 scion xd with similar problems the engine will start but will not allow to go into drive and wipers.. Ac.. Windows.. And radio do not work do you have any ideas or find out what was causing your problem.. I know it is not alternator

SJMiller 11-18-2014 07:53 PM

2011 xD No Issues
 
Probably shouldn't add to this thread in case it bring some bad ju ju, but my 2011 xD with 43,000+ miles has had absolutely no issues. I love it. One of the best small cars I've even owned.

I better go find some wood to knock on quick now lest it falls apart.

scottd250 06-23-2015 05:48 PM

2012 xd ac drain clogged
 
i have been chasing what i thought was some kind of leak for the past few days.thanks to this forum i found the easy fix for the clogged ac drain.there was enough water in there that when i turned left the blower motor actually sprayed some water out of the vents on the dash.:jawdrop:......this is definitly something to put on a routine check list.thanks everyone!


All times are GMT -5. The time now is 02:04 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.