Go Back   Scion XD Forum > xD Modification > Engine/Performance

Engine/Performance All things engine and performance.


Reply
 
Thread Tools Display Modes
Old 08-05-2016, 12:36 AM   #1
jhalski
Junior Member
 
Join Date: Aug 2016
Name: James
Posts: 1
Default Cylinder 1 Misfire - Rough Idle - Troubleshooting
Hey Guys,

My GF has a 2008 Scion xD with 196k miles on it. Recently it threw a Cylinder 1 misfire code and has a rough idle only when in drive or the A/C or engine Fan turns on, then the rpms drop from about 800 to about 500 and the car shakes pretty bad. Below are the troubleshooting steps i've taken so far.

Before we start this, looking at the engine from the front, Cylinder 1 is on the far left correct?

1) Changed all spark plugs (they all seemed okay, Cylinder 1 was a little rougher than the others, to be expected)

2) Check coil packs - engine running, i removed them one by one, they are all working, i swapped Coil pack #1 and #2 just to be sure, i did NOT get a cylinder 2 misfire, still cylinder 1. Coil Packs seem okay.

3) Replaced Fuel injector on Cylinder 1 - I thought it began to run better (i forgot to turn the a/c on, maybe thats why) then i noticed it started leaking fuel out of it, the O ring broke, so i replaced it, and we're back to square one. Same cylinder 1 misfire.

I read somewhere someplace that unhooking the battery, then letting it idle for 10min worked for someone...gave that a try, no change.

I'm not sure what else to try here. Working on it tonight with my headlamp i did notice a bit of what i think is an exhaust leak around cylinders 1 and 2. Could that be causing an issue? I did see an O2 sensor code thrown once, but i cleared it all and it hasn't come up again.

The engine idles/shakes much rougher whenever the engine fan kicks on or i turn the A/C on, soon as i take it off it idles much better.

Anyone have any thoughts or ideas to help me out? It would be much appreciated, thanks!

EDIT: After doing some more research, that leak in the exhaust, that seems like it could cause some compression issues and maybe cause the cylinder to misfire....does that sound correct?

Last edited by jhalski; 08-05-2016 at 02:56 AM.
jhalski is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump