Go Back   Scion XD Forum > xD Modification > Engine/Performance

Engine/Performance All things engine and performance.


Reply
 
Thread Tools Display Modes
Old 01-26-2013, 06:22 PM   #1
braden181818
Junior Member
 
Join Date: Jan 2013
Name: Braden
Age: 35
Posts: 2
Default Crazy Electrical problem.......
I have a 2008 Scion XD. Was driving the car down the highway on a slightly rainy day. Out of nowhere the Power steering went out, the wipers stopped working, the Heater/AC stopped, the blinkers stopped working, the radio went out, the windows stopped working and there were random lights on the dash like the Brake light, and some other random ones, but not the battery light. The car still kept running fine other wise. The alternator is fine, the battery is good, there were no blown fuses. Could this all be caused by the power steering ECU, or maybe the Engine ECU?
braden181818 is offline   Reply With Quote
Old 01-27-2013, 11:37 AM   #2
 
xd_kidd's Avatar
xd_kidd
OG Member
Full Access Member
 
Join Date: Sep 2009
Location: gaithersburg md
Name: chris
Age: 27
Posts: 616
Default
An ecu malfunction would be my best bet if it has multiple electrical problems


__________________
Originally Posted by simmons0613 View Post
DA DADA! xd_kidd comes to save the day!
xd_kidd is offline   Reply With Quote
Old 02-19-2013, 04:37 PM   #3
 
JDMJim's Avatar
JDMJim
OG Member
Full Access Member
 
Join Date: Oct 2009
Name: jim
Age: 45
Posts: 576
Default
water on the ECU?
JDMJim is offline   Reply With Quote
Old 02-27-2013, 06:05 AM   #4
honeyfree
Junior Member
 
Join Date: Feb 2013
Name: honey
Age: 23
Posts: 1
Default
The alternator is fine, the battery is good, there were no blown fuses. Could this all be caused by the power steering ECU, or maybe the Engine ECU?


__________________
hi
honeyfree is offline   Reply With Quote
Old 04-11-2013, 05:01 PM   #5
 
simmons0613's Avatar
simmons0613
OG Member
Full Access Member
 
Join Date: Nov 2010
Location: Middleburg, Florida
Name: Matt
Age: 27
Posts: 415
Default
I had the same problem about a year ago, but my alternator just blew. You might want to double check it.


simmons0613 is offline   Reply With Quote
Old 04-17-2013, 11:15 PM   #6
Flaisig Rally XD
Junior Member
 
Join Date: Apr 2013
Name: Matt
Age: 27
Posts: 6
Default
OMG i am having this same problem. Mine happened when I was rally crossing. I have had the alternator checked they said it was fine. Branden have you figured it out?
Flaisig Rally XD is offline   Reply With Quote
Old 04-19-2013, 01:37 PM   #7
 
simmons0613's Avatar
simmons0613
OG Member
Full Access Member
 
Join Date: Nov 2010
Location: Middleburg, Florida
Name: Matt
Age: 27
Posts: 415
Default
I dont know if these cars have one but it might be a voltage regulator.


simmons0613 is offline   Reply With Quote
Old 04-22-2013, 12:50 PM   #8
Flaisig Rally XD
Junior Member
 
Join Date: Apr 2013
Name: Matt
Age: 27
Posts: 6
Default
I believe the voltage regulator is built in to the alternator.
Flaisig Rally XD is offline   Reply With Quote
Old 04-26-2013, 12:45 AM   #9
steezie
Junior Member
 
Join Date: Apr 2013
Name: jay
Age: 36
Posts: 1
Default
sounds like your 2nd ignition lost power. typically its from the ign harness/selenoid
steezie is offline   Reply With Quote
Old 04-26-2013, 03:09 PM   #10
Flaisig Rally XD
Junior Member
 
Join Date: Apr 2013
Name: Matt
Age: 27
Posts: 6
Default
what is the ign harness/selenoid.

My car is also a manual when i look up the ign it takes me to the AT

Last edited by Flaisig Rally XD; 04-26-2013 at 11:37 PM.
Flaisig Rally XD is offline   Reply With Quote
Old 05-05-2013, 10:34 PM   #11
scionwithbass
Junior Member
 
Join Date: Nov 2012
Name: Cameron Bluhm
Age: 23
Posts: 8
Default
Get it figured out yet? Cause I loaned Flaisig Rally my alt and batt and like he said, did nothing, also tryed relays.
scionwithbass is offline   Reply With Quote
Old 05-28-2013, 10:54 AM   #12
Flaisig Rally XD
Junior Member
 
Join Date: Apr 2013
Name: Matt
Age: 27
Posts: 6
Default
Any Update?
Flaisig Rally XD is offline   Reply With Quote
Old 06-03-2013, 12:15 PM   #13
Flaisig Rally XD
Junior Member
 
Join Date: Apr 2013
Name: Matt
Age: 27
Posts: 6
Default
Okay Took it to a shop and they gave up. Really need a update on this one.
Flaisig Rally XD is offline   Reply With Quote
Old 06-06-2013, 10:12 AM   #14
JerryWright
Junior Member
 
Join Date: Jun 2013
Name: Enter your name or name you wish to be refered to as.
Age: 28
Posts: 1
Default
Originally Posted by braden181818 View Post
I have a 2008 Scion XD. Was driving the car down the highway on a slightly rainy day. Out of nowhere the Power steering went out, the wipers stopped working, the Heater/AC stopped, the blinkers stopped working, the radio went out, the windows stopped working and there were random led light on the dash like the Brake light, and some other random ones, but not the battery light. The car still kept running fine other wise. The alternator is fine, the battery is good, there were no blown fuses. Could this all be caused by the power steering ECU, or maybe the Engine ECU?
Such problem occurs sometime. Battery stopped working for a while or could be some other strange issue. If the car is still fine you should not be worried

Last edited by JerryWright; 06-07-2013 at 10:18 AM.
JerryWright is offline   Reply With Quote
Reply

Bookmarks

Tags
accessories, electrical issue, power steering


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump